Archive

Archive for febbraio 2013

Bare Metal Backup issue of Windows Server 2008 R2 on Dell hardware – Part 2

Proseguo il post di ieri per dire che il backup non è andato a buon fine perchè ha presentato l’errore seguente

bck_home_05

che nei dettagli di Windows Server Backup è rappresentato col codice di errore 0x81000101.

La ricerca di questo errore porta rapidamente a questa soluzione di danma_

Windows Server Backup failed to backup with error 0x81000101

Symptom:

Sometimes Windows Server Backup failed to backup the data. The error is:

The shared restore point operation failed with error (0x81000101) The creation of a shadow copy has timed out. Try this operation again.

In the event viewer, found the following error:

The backup operation that started at ‘‎**** has failed because the Volume Shadow Copy Service operation to create a shadow copy of the volumes being backed up failed with following error code ‘2155348001’. Please review the event details for a solution, and then rerun the backup operation once the issue is resolved.

Cause:

Windows Server Backup is timing out during shadow copy creation since it is taking more than 10 minutes.

Resolution:

– Run regedit.exe and navigate to “HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\SPP”

– Create a new Registry value of type DWORD with name “CreateTimeout”

– Change value to 12000000(2*10*60*1000 = 20 mins) in decimal

che risolve il problema infatti al backup successivo ottengo

bck_home_06

Bare Metal Backup issue of Windows Server 2008 R2 on Dell hardware

Mi trovo a dover affrontare tre situazioni completamente diverse ma tutte caratterizzate da un fattor comune che è l’impossibilità di eseguire un backup.

La prima di queste situazioni si verifica sul mio Windows Server 2008 R2 Datacenter con Hyper-V di casa che è installato su hardware Dell.

Il problema che si manifesta tentando l’esecuzione di un backup “one shot” è quello rappresentato qui

bck_home_01

ed è dovuto ad una situazione dei dischi che vediamo nell’immagine del Disk Manager qui sotto

bck_home_02

La soluzione me l’ha fornita Bob Duffett(Partner) nel post che riporto integralmente di seguito

Again, thanks!

I ran the backup and got the following error:

Retrieving volume information… One of the source volumes specified has an invalid format and cannot be protected using Windows Backup. Only volumes formatted with NTFS can be protected.

This has me back to my suspicion that one of my non-NTFS volumes is causing the problem.

MOUNTVOL returns:

Possible values for VolumeName along with current mount points are:

   \\?\Volume{e95810a3-9a06-11df-aba4-806e6f6e6963}\

       *** NO MOUNT POINTS ***

   \\?\Volume{e95810a4-9a06-11df-aba4-806e6f6e6963}\

       C:\

   \\?\Volume{e95810a7-9a06-11df-aba4-806e6f6e6963}\

       D:\

fsutil fsinfo volumeinfo\\?\Volume{e95810a3-9a06-11df-aba4-806e6f6e6963}\  returns:

Volume Name : OS

Volume Serial Number : 0x7da0716

Max Component Length : 255

File System Name : FAT32

Preserves Case of filenames

Supports Unicode in filenames

That drive shows as OS, 2.01 GB FAT32, Healthy (System, Active, Primary Partition)

Ahhhl  I just found a couple threads that help!

http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/a79a4eeb-8ac3-4442-aa0c-76d83ebb7e47

http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/d6a5b150-dd71-4bfb-a5c6-c53310dd3c2f

Using Remote Desktop connected to my new Domain Controller, I went to an Admin Command prompt,

1. I ran DSKMGMT.MSC and changed the drive letter of the FAT32 partition to be a drive letter (F: in my case).  It didn’t have a letter prior to this.  Ultimately this step wasn’t needed.

2. Then I ran the following:

C:\Windows\system32>bcdboot c:\windows /s c: Boot files successfully created.

This moved the Boot attribute off of the OS partition and placed it on the C:

3. I then typedDISKMGMT.MSC, right-clicked on C: and selectedMark Partition as Active

4. I rebooted and 2 minutes later it booted!!!

5. I ran DISKMGMT.MSC again and removed the drive letter from the FAT32 partition and then quick formatted it as NTFS.

6. Rebooted just for grins and it came back up just fine.

Now that the FAT32 partition is gone, I tried:

      wbadmin.exe start backup -allcritical -quiet -backuptarget:\\server\bmrshare

It ran just fine.

Went to DPM 2010 Mgmt console and ran a Consistency Check. Protection Status is OK for BMR on both DC’s now!

This thread can be closed. Thank you for your help, Mike!

Bob

unitamente al post di Abhinav Mathur (MSFT) che leggete qui

Hi,

I will suggest the use of the bcdboot.exe tool in this scenario. More info about the tool here http://technet.microsoft.com/en-us/library/dd744347(WS.10).aspx
Move the system volume to c:\, this can be done using the following command, run on an elevated command prompt. (Even though it is known from above, still double check that C: is on a primary partition on disk 0, not on a logical partition).

bcdboot c:\windows /s c:

then in diskmgmt.msc, rightclick on c:, mark the c: partition as ACTIVE. Then reboot.
After reboot, check which partition is marked as active and system, it should be C:. By this mechanism, even if something fails, you can revert the old system partition F: as active, it is not yet deleted or formatted to NTFS, using diskpart from the windows installation cd.

Try a backup with -allcritical option, only c: should be backed up as the critical volume.

Now try converting the old system partition F: to NTFS using convert.exe. Since it was the system partition, earlier a volume handle was open to it, it should work now. Please note it is recommended to keep the boot and the system partition separate, for applications like Windows BitLocker to work.

Thanks,
Abhinav

Fatte le operazioni indicate nel primo dei due posts mi sono ritrovato con la situazione dischi rappresentata qui sotto

bck_home_03

Purtroppo nel mio caso il server non svolge il ruolo del domain controller ma il ruolo del hypervisor e lo spostamento della partizione marcata come Boot e System ha comportato la disattivazione dell’hypervisor stesso e il mancato avvio delle macchine virtuali in esso installate.

Il controllo dei requisiti di virtualizzazione nel bios ha confermato che tutto era rimasto configurato in maniera corretta pertanto sono stato costretto a rimuovere e reinstallare il ruolo Hyper-V per fare in modo che l’hypervisor partisse in maniera corretta all’avvio del server.

Fatta questa operazione, il tentativo di avvio di una delle virtual machine mi ha segnalato un errore diverso: mancava la configurazione di rete ed infatti ho scoperto che la rimozione del ruolo Hyper-V mi ha fatto perdere la configurazione delle Virtual Networks ripristinata rapidamente visto che ricordavo esattamente come dovevano essere configurate.

A quel punto le macchine virtuali, con le virtual networks rimesse in modo corretto, sono ripartite.

Fatto ciò, ho potuto sperimentare l’esecuzione del backup “one shot” che ora è in esecuzione così

bck_home_04

Vedremo se tutto andrà a buon fine.

My Award Rings

my_rings

MVP Milestone Award

milestone_award

Carissimo Edoardo Benussi,
Congratulazioni! A riconoscimento dei tuoi continui contributi community come MVP, Microsoft ha deciso di onorare questo importante risultato con un “custom award disk” da aggiungere al tuo MVP Crystal Wedge Award.

Il disco ti arriverà molto presto.
Il Microsoft MVP Award Team celebra con te questo riconoscimento.

A nome di tutta Microsoft, ti faccio tanti complimenti per aver continuato, negli anni, a dare un significativo apporto alle community come MVP.

Mike Hickman Director Community Engagement Microsoft