Home > Backup, IT Pro, Server, Technical post, Virtual machines, Virtualization > WARNING: Found virtual disks that are Degraded

WARNING: Found virtual disks that are Degraded

Il rientro dalle vacanze non è quasi mai cosa gradita ma l’opinione peggiora quando, tornati a casa, si trova che tutta la rete locale risulta inacessibile: il wifi funziona ma il dhcp non fornisce gli indirizzi a smartphones e portatili.

Che succede ?

Vado nello studio per verificare lo stato delle macchine virtuali sul mio Hyper-V e trovo l’host con il cursore del mouse visibile ma lo schermo nero. What ?

Come da prassi in tutti i sistemi Windows applico la soluzione classica: spengo e riaccendo🙂

Al riavvio, quando carica il driver del controller PERC S300, noto il messaggio in oggetto come lo vedete qui sotto

wpid-20140620_072824.jpg

ma lascio proseguire il boot fino ad ottenere il classico messaggio di Windows che esorta ad eseguire un chkdsk del disco e quando lo eseguo ottengo un fatal error.

Spengo e riaccendo nuovamente e scegliendo la modalità provvisoria con rete riesco a vedere il desktop del mio host fisico verificando che i dischi si vedono tutti.

Riavvio nuovamente ma lasciando proseguire il boot in modalità normale, torno ad ottenere lo schermo nero con il solo cursore del mouse visibile.

Mmmmhhh….. quel warning sul virtual disk degradato è il primo punto da risolvere.

La ricerca su internet fornisce come primo risultato questo

http://support.dell.com/support/systemsinfo/document.aspx?c=us&l=en&s=hea&~file=/storage/storlink/perc_s100_s300/en/html/a5_sectl.htm

per cui riavvio nuovamente e, al momento del caricamento del driver del controller, premo <Ctrl><R> per visualizzare la PERC Virtual Disk Management utility.

Nell’utility verifico che il virtual disk è degraded perchè due dei tre phisical disks sono in stato Online mentre uno è in stato Ready, ossia la stessa situazione descritta qui

http://en.community.dell.com/support-forums/servers/f/906/t/19536933.aspx

perciò provo a riavviare in provvisoria con rete, scaricare l’OpenManage Server Administrator, peccato che in provvisoria non posso installarlo e in modalità normale non ho l’interfaccia grafica funzionante per poter agire.

Cerco ancora e trovo finalmente questo

http://en.community.dell.com/support-forums/servers/f/906/p/19492623/20305330.aspx

quindi riavvio nuovamente e, al caricamento del controller, premo <Ctrl><R> per avviare la PERC Virtual Disk Management utility. Da questa vado ad assegnare il disco in stato Ready come Global Hot Spare e riavvio nuovamente la macchina.

Dopo questo ultimo riavvio giungo nuovamente alla fatidica esortazione di Windows di eseguire il chkdsk e questa volta il controllo del disco parte

wpid-20140621_120507.jpg

purtroppo eliminando qualche indice ma ben poca roba.

Al termine ottengo finalmente la tanto sospirata interfaccia grafica dell’host Hyper-V, accedo e avvio l’OMSA OpenManage Server Administrator in cui verifico che l’array del RAID 5 è in stato Rebuilding.

Intanto è partito l’hypervisor e tutte le macchine virtuali funzionano regolarmente ad eccezione del server virtuale che ospita l’Exchange e che crasha quando avvia tutti i servizi. Poco male, un bel bare metal recovery con un’immagine scelta tra quelle salvate la settimana precedente e tutto torna perfettamente funzionante.

Tutto è bene quel che finisce bene🙂

  1. Non c'è ancora nessun commento.
  1. No trackbacks yet.

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger cliccano Mi Piace per questo: